How to do BGP with MikroTik Router and TR7?
About
How to do BGP with MikroTik Router and TR7?
Dynamic Routing Protocols are supported on the TR7 ASP device. By activating it, the desired protocol is activated.
Supported Dynamic Routing Protocols:
- BGPD
- OSPFD
- OSPF6D
- RIPD
- RIPNGD
- ISISD
- PIMD
- LDPD
- NHRPD
- EIGRPD
- BABELD
- SHARPD
- PBRD
- BFDD
- FABRICD
- VRRPD
- PATHD
Interface
How is BGP Done?
Step > 1
"Settings Mode > Network > Route Tables" steps are followed. On the screen that opens, the Add
button is clicked.
Step > 2
On the screen that opens, the "Dynamic Route Table" button is activated. The dynamic route protocols supported by the Dynamic TR7 ASP are listed.
Step > 3
FRR Mode: "traditional" is selected. "BGPD" is activated. Add
button is clicked and saved.
Step > 4
"Setting Mode > Network > Interfaces" steps are followed. The relevant Interfaces are edited and added to the route table defined in "BGPD". (Ex: 10G-1 -10G-2 Interfaces)
Step > 5
By editing the relevant interfaces (10G-1 – 10G-2), IP definitions are made for both interfaces.
Step > 6
On the TR7 web interface, click on the terminal icon from the left submenu. On the screen that opens, select the "BGP (VTYSH)" that you created from the Route Table selection tab.
The following commands are run in order.
- configure terminal
- interface 10G-1
- ip address 192.168.2.1/24
- !
- exit
- interface 10G-2
- ip address 10.10.10.2/24
- !
- exit
- ip prefix-list ALLOW-ALL seq 5 permit 0.0.0.0/0 le 32
- route-map ALLOW-ALL permit 10
- match ip address prefix-list ALLOW-ALL
- exit
- router bgp 65020
- bgp router-id 10.10.10.2
- neighbor 10.10.10.1 remote-as 65010
- address-family ipv4 unicast
- network 192.168.2.0/24
- neighbor 10.10.10.1 route-map ALLOW-ALL in
- neighbor 10.10.10.1 route-map ALLOW-ALL out
- exit-address-family
- exit
- exit
- write memory
The following command is run to check the connection.
- show ip bgp summary